Instalacja, htaccess, podkatalog i home.pl

Wszelkie dyskusje na temat instalacji i aktualizacji Opencart w wersji 1.0 i wyższej.

Re: Instalacja, htaccess, podkatalog i home.pl

Postprzez adikon.oc » 10 lut 2014, o 18:51

Jeżeli to nie działa to raczej szukaj przyczyny w serwerze a nie OC
Kod: Zaznacz cały
Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
#<FilesMatch "\.(tpl|ini|log)">
# Order deny,allow
# Deny from all
#</FilesMatch>

:Location ".*\.(tpl|ini|log)"
access deny from all
:Location

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
oczywiście jak sklep jest w podkatalogu to trzeba zmienić RewriteBase / na RewriteBase /katalog/
adikon.oc
 
Posty: 603
Dołączył(a): 28 gru 2010, o 22:56

Re: Instalacja, htaccess, podkatalog i home.pl

Postprzez wojtaloux » 7 sty 2015, o 02:47

ja też miałem podobny problem bo nie miałem za bardzo gdzie tych plików umieścić. Rozwiązałem to tak:
1)zrobiłem autoinstalację wordpressa dla danej domeny przez panel home.pl
2)przez FileZille wywaliłem wszystkie pliki z katalogu autoinstaller/wordpres i wgrałem tam pliki sklepu.
O dziwo instalacja zadziałała, ugrzązłem dalej :D
wojtaloux
 
Posty: 4
Dołączył(a): 7 sty 2015, o 02:23

Re: Instalacja, htaccess, podkatalog i home.pl

Postprzez wojtaloux » 7 sty 2015, o 02:59

wojtaloux napisał(a):ja też miałem podobny problem bo nie miałem za bardzo gdzie tych plików umieścić. Rozwiązałem to tak:
1)zrobiłem autoinstalację wordpressa dla danej domeny przez panel home.pl
2)przez FileZille wywaliłem wszystkie pliki z katalogu autoinstaller/wordpres i wgrałem tam pliki sklepu.
O dziwo instalacja zadziałała, ugrzązłem dalej :D


Już się wygrzebałem, musiałem jeszcze w katalogu wordpressa utworzyć katalog tmp i działa :)
wojtaloux
 
Posty: 4
Dołączył(a): 7 sty 2015, o 02:23

Poprzednia strona

Powrót do Instalacja i aktualizacja systemu Opencart

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości